For all the missing dll things on Windows

Information about Xmoto Releases

Moderators: Main Administator, Global Moderator, Moderator

Post Reply
Wak
Xmoto Player
Xmoto Player
Posts: 2
Joined: Fri May 29, 2009 5:37 pm

For all the missing dll things on Windows

Post by Wak » Sat Nov 22, 2014 8:49 pm

The X-moto installers for Windows are badly packed and miss libxml2-2.dll and com with two wrong dlls.
Here is how to fix it (Note: Don't download dll files from downloading sites. You don't know whether they are modified or not and they are insecure.):

1) Missing LibXml2-2.dll. Download it from the official website.
    a) go to ftp://xmlsoft.org/libxml2/win32/64bit/
    b) download the 32-bit one, currently it is ftp://xmlsoft.org/libxml2/win32/64bit/[ ... n32-x86.7z[/b][/i]
    c) find and extract libxml2-2.dll and place in C:\Program Files (x86)\XMoto
2) LibIconv-2.dll
    a) Download YAMB from http://yamb.unite-video.com/download.html
    b) install and note to check MKVExtract during installing
    c) you can find a copy of libIconv-2.dll in C:\Program Files (x86)\Yamb\mkvextract
    d) copy the dll to C:\Program Files (x86)\XMoto
3) zlib1.dll, the dll is too old and not working
    a) you can find a copy of zlib1.dll, in C:\Program Files (x86)\Yamb\mkvextract
    b) copy the dll to C:\Program Files (x86)\XMoto

It is hard to believe they put out installers with this quality.

shmo
Administrator
Administrator
Posts: 548
Joined: Fri Nov 16, 2012 4:55 pm

Re: For all the missing dll things on Windows

Post by shmo » Sun Nov 23, 2014 2:53 am

What bug does this fix? I've know the installer was bad but it does work if you download the zip...
Did you know that the tip of a lighter flame smells like burnt nose hair?

XF_
Xmoto Player
Xmoto Player
Posts: 13
Joined: Fri Apr 06, 2012 7:40 pm

Re: For all the missing dll things on Windows

Post by XF_ » Sun Nov 23, 2014 10:14 pm

The win32.zip works, don't use the setup files.

Infinity
Main Administator
Main Administator
Posts: 14
Joined: Sat Dec 21, 2013 8:26 am

Re: For all the missing dll things on Windows

Post by Infinity » Tue Jan 06, 2015 10:29 pm

Hey,

    I believe that the installer is working fine now - I noticed a problem in the makefile for the installer, and submitted a correction that has since been published. Just download the latest exe from the site and it should work fine.

Cheers,
xmotoplayer

Post Reply

Return to “Xmoto Releases”

Who is online

Users browsing this forum: No registered users and 1 guest